Приключенията на един клъстер, част 2
Вероятно не всички знаят какво означава „ASM не е успял да си монтира дисковете” . Това е все едно да имаш данните си на един диск, който откачаш при спиране на сървъра. После, при пускане на сървъра закачаш диска и той ти казва „А, ми то тука няма диск, няма данни, няма дявол!”. Тръпката е значителна!
Последва няколко часа борба с ASM. Съобщението в alert log-а е следното:
SQL> ALTER DISKGROUP ALL MOUNT
NOTE: cache registered group DGMJ0001 number=1 incarn=0x0cd54fbd
ERROR: no PST quorum in group 1: required 2, found 0
NOTE: cache dismounting group 1/0x0CD54FBD (DGMJ0001)
NOTE: dbwr not being msg'd to dismount
ERROR: diskgroup DGMJ0001 was not mounted
Съвсем естествено, няма нищо смислено по въпроса нито в MetaLink, нито в Google.
(Защо е естествено? Май забравих да спомена, че тези премеждия се случиха на петък 13-ти…)
Опитах да вдигна групата с молби, със заплахи, със своеобразно „подритване”… Дори kfod не успя да я познае. След 3 часа извадих последния си коз – премахнах новите voting disks. Звучи крайно нелогично, защото ако има проблем с voting disk, няма да се вдигне клъстерната услуга (CRS). ASM услугата изобщо не се занимава с voting disks и други такива – тя се обръща към CRS и той се оправя нататък.
Да, ама не съвсем. Поради неясни причини, след премахването на трите нови voting disks, всичко тръгна. Само дето се върнах в изходно положение.
(продължението – когато намеря още малко време)
Sorry, the comment form is closed at this time.