Ное. 162007
 

Най-после и аз се престраших да си upgrade-на blog-а. Скока е голям – от WordPress 1.5.1.3 на WordPress 2.3.1.

Учуден съм колко лесна е процедурата. Първо си бекъпнах всичко според инструкциите за Backup; спрях плъгина против спам (аз друг плъгин не използвам); после копирах внимателно новите файлове според инструкциите за Upgrade и пуснах /wp-admin/upgrade.php.

Е, не мина без абсолютно никакви проблеми. Повяиха се разни надписи преди всеки пост:

Warning: array_key_exists(): The first argument should be either a string or an integer in /www/yavor.org/blog/root/wp-includes/category-template.php on line 176

Това, обаче, е мотика, настъпвана и преди (от други). Според съветите на знаещите, отворих си index.php на темата (MistyLook 2.3) и промених ред 15 от

< ?php if (in_category($AsideId) && !is_single() ) : ?>

на

< ?php if ( $AsideID != '' && in_category($AsideId) && !is_single() ) : ?>

Толкова! Сега предстои да разбера и каква ми е далаверата ит новия WordPress (т.е. да се науча да го използвам)

p.s. Така и така съм почнал, сложих си и новата версия на темата, MistyLook 3.5.

 Posted by at 15:28

  2 Responses to “WordPress Upgrade”

  1. Честитим!
    Със здраве да си потреблявате новата придобивка! 🙂

    Поздрави

  2. […] Отново съм впечатлен от безумно простата процедура. Предния път имах малко драми с темата, но сега всичко си мина […]

Sorry, the comment form is closed at this time.